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Adobe Fireworks CS4 

Adobe Fireworks CS4 blends the best qualities of Adobe Photoshop and Adobe 

Illustrator, while simplifying both.  And because the World Wide Web is full of both 

photographs and illustrations, Fireworks is the natural solution for editing images or other 

graphics to go online.   

 

 

 

 

 
 

 

 

 

 

Panels give many different options for editing and changing your images.  For example, 

the Layers Panel displays any layers you have in your image so they can be edited 

separately.  The Colors Panel provides many color options to create for stroke or fill 

colors, as well as preset swatches to choose from. 

 

4.  Tools Panel 



The Property Inspector allows you to view or change properties of a tool or an object.  

For example you could change the size or type of stroke of your brush.   The Property 

Inspector is context sensitive.  So each time you choose a different tool or select an object 

the options in the Property Inspector will change accordingly.  The Property Inspector 

can be viewed at full size or half size.  The small triangle in the bottom right hand corner 

of the Property Inspector is the toggle switch for full and half view.   

 

The Tools Panel shows all the available tools you have to make selections, draw shapes, 

edit images, and crop images.  The Tools Panel has 6 sections: Select, Bitmap, Vector, 

Web, Colors, and View.  Select allows selection and resizing of objects.  Bitmap has 

tools for selecting and editing pixels.  Vector has tools for creating and changing vector 

shapes and text. (See the section on Bitmap vs. Vector).  Web has tools specific to Web 

applications such as hotspot tool or the slice tool.  Colors has options for choosing stroke 

or fill colors.  View allows you to zoom or pan your image. 

 

If you have more than one image open at a time and the window is maximized there are 

tabs at the top of the Document Window.  You can quickly move between images just by 

clicking on the tab of the image you want to view. 

 

If you want a larger view of the Document Window you can use the F4 toggle to turn on 

and off all the panels and the tools.   

 

The Document Window also has a couple of unique buttons in the upper right hand side 

under the standard minimize, maximize and close buttons. The one on the right with the 

Fireworks symbol opens the Quick Export menu and allows you to easily export your 

image to other programs or to preview it in a browser.  The double 

arrows are for putting or getting your file from a remote web site.   

 

The bottom of the document window has the image size, a drop down menu for zoom 

options and an edit bitmap mode circle.  The small circle with the white X, when red 

signifies you are editing in bitmap mode.   



Creating and Saving a New Image 

 

From the Fireworks Start Page click on the Fireworks 

File in the Create New section. Alternately, from the 

File menu, click on New. Either option will open the 

New Document dialog box. 

 

Choose the width and height (for web applications it 

is best to use a pixel dimension and 72 pixels/inch is a 

good resolution).  The Canvas, which is what you 

build your image on, can be white, transparent (no 

color at all) or you can choose a Custom color.  

If you have an image copied to the clipboard and then 

open a new document it will default to the correct size of the item on the clipboard.  Then 

you paste in your image and it fits the canvas.   

Save your file early and often so you donôt have to worry about losing any of your 

changes to your file.  There is also a Save as a Copy option.  If you save your file and 

choose Save as a Copy, it will save the file as it is but leave the original open for you to 

continue working on.  If you just Save As, it will close the original file and open the 

newly created file.   

 

Fireworks creates images in a .PNG file format.  That is a Portable Network Graphics 

file.  The .PNG file can have transparency and uses a lossless data compression.  That 

means it compresses (makes smaller) a file with minimal loss of quality.  The .png file 

was created as a replacement for the .gif file which was a patented file format.  .PNG files 

are not universally recognized by browsers, so when creating an image the best practice 

is to save it in the native Fireworks format .png and then Save As a .jpg or .gif to use on 

the internet.  Your image can be saved in many file formats. The .jpg format is usually 

the best for photos with many colors and color shades.  The .gif format is usually the best 

for an illustration or an image with lines and solid color fills.   

 

 

Open an Existing File 

You can open existing files from the file menu.  For a recently opened file choose File > 

Open Recent and choose from the up to 10 last viewed files.  Or go to File > Open and 

navigate to the file you want. 



Bitmap vs. Vector 

 

Before learning to edit or manipulate images, it is important to know the difference 

between a bitmap (also called Raster) image and a vector image.   

 

Bitmap 

The Bitmap is probably the most common type of image you find.  A bitmap image is 

like a grid with a color in each cell.  On screen a pixel is a square of color. If you print a 

bitmap the printer prints dots of color.  Since there are a limited number of colors of ink, 

a printer overlaps colors to make the color needed.  The computer screen is capable of 

displaying over 16 million colors, so each pixel is just one color.  To make a smooth 

transition, each pixel changes color just a little to fool the human eye to see a specific 

color.   

Because each pixel is a different color it is hard to resize bitmap images perfectly.  If you 

want to make your image smaller you have to throw out some pixels.  That works pretty 

well.  However, if you are trying to increase the size of a bitmap image the program will 

have to create pixels using a formula to add them into the image.  This works pretty well 

in small increases, but if you try to increase the size considerably, the colors may not 

match as well as could be desired.  This type of image is called resolution dependent as it 

is dependent on the number of pixels that are in the file. 

 

Vector 

A vector image is a resolution independent image because it does not rely on pixels.  

Instead a vector image uses lines, curves and fill colors to make up the image.   

A vector image could be described as  

¶ Circle: (200cm) 

¶ Fill color: Gradient 

¶ Gradient type: Radial 

¶ Colors:  Black, Red 

¶ Line color: none 

This is quite different than literally mapping out each and every pixel. 

 

Vector graphics size very well as the only thing that needs to change is the size. Vector 

objects consist of many points all of which can be edited.  Vector graphics are good for 

illustrations and logo type images.  Images with many colors and color changes would 

not look good in a vector format. 



Fireworks Tools 

 

In order to edit or manipulate images Fireworks provides many different tools.  

The tools are in six sections: Select, Bitmap, Vector, Web, Colors, and 

View. To choose a tool, click and release.  Any tool that has a small dark 

triangle next to it has alternate tools underneath. To choose the alternate tools, 

click and hold over the tool. Each tool also has a tool tip giving the name of 

the tool. To get the tool tip, hover over the tool. 

Each tool selected brings up various options in the Property Inspector.  If you 

canôt see the tool options, you may have the image selected.  Deselect the 

image from the menu Select > Deselect.   

Select 

The Select tools are used to select, move and resize images.  The dark pointer 

selects or drags objects or images.  To select more than one image or object 

click to select the first object and shift click the other objects. 

Under the selection tool is the Select behind tool.  Use this if 

objects are stacked and the one you want is behind (actually under) 

another object. 

 

The smaller white arrow is the subselection tool. This tool will 

select individual points in a vector image or objects in a group. 

 

Under the white arrow is the crop tool.  Cropping deletes areas of the image 

outside the rectangular area you want to keep. Click and drag the crop tool in a 

bitmap image to select the part of the image you want to keep.  You can resize 

crop area by clicking and dragging on the sizing handles.  Click and drag the 

crop area to reposition it.  Hit the Enter key to activate the crop. 

 

The last tool in the Select area is the Distort tool.  Using this tool allows you to 

scale, skew or rotate your image. 

Bitmap 

The Bitmap tools allow you to select or alter pixels in a bitmap image.  The 

marquee tool creates a selection area.  Choose the marquee tool bring your 

cursor into your image and click and drag to create a rectangle area or hold the 

shift key while dragging to create a perfect square.  Under the marquee is the 

Oval marquee tool to create oval or round selections.  Once a selection is 

created, you can hold the shift key and make a new selection to add to the 

original selection.  Hold the Alt key and make a new selection to subtract that 

selection from the original.  Holding the CTRL key will allow you to move the 

selected area of the image. Selections can be hard edge which will select pixel 

by pixel, anti-alias which will soften the edges by adding less opaque pixels to smooth 

out the square stair stepping of the pixels or feather which will start out opaque and move 



to transparency with a size you set in the feather option in the Property Inspector. A quick 

way to deselect is to use the keyboard shortcut CTRL + D. 

 

The lasso tool is similar to the marquee, but you control the selection by hand.  Under the 

lasso tool is the polygon lasso tool which selects in straight lines creating a polygon 

selection.   

 

The pencil and brush are very similar and allow you to draw on your image.  The brush 

is different from the pencil in that you can change the width and density.  Change colors 

in the property inspector.  

The eraser deletes selected pixels in bitmaps only 

 

The magic wand tool selects by color.  The tolerance factor is how many similar colors 

to the one pixel you click on you want to select.  The tolerance can be from 1 which 

would select only the exact color you chose, up to 255 which would choose all colors. 

 

Fireworks provides a wide range of tools to help you retouch your images. You can alter 

an imageôs size, reduce or sharpen its focus, or copy and "stamp" a part of it to another 

area. 

 ¶ The Rubber Stamp tool lets you copy or clone one area of an image to 

another. 

 ¶ The Blur tool decreases the focus of selected areas in an image. 

 ¶ The Smudge tool picks up color and pushes it in the direction that you drag 

in an image. 

 ¶ The Sharpen tool sharpens areas in an image. 

 ¶ The Dodge tool lightens parts of an image. 

 ¶ The Burn tool darkens parts of an image. 

 ¶ The Red-eye Removal tool reduces the appearance of red eye in photos 

 ¶ The Replace Color tool paints over one color with another color 

 

Vector 

Vector tools allow you to create vector graphics or manipulate points in a vector graphic.  

You can create straight lines with the line tool, curved lines with the pen 

tool, vector paths with the path tool, vector shapes with the shape tool, text 

with the text tool.   

To create straight lines, choose the line tool and click and drag on your 

canvas.  There are several vector shapes to choose from.  Click on the 

shape you want and click and drag on your canvas to size the shape.  In the 

property inspector choose a fill color or stroke color if desired.   

The knife tool cuts vector objects apart. 



The pen tool can be very tricky.  Click a point to start and to make a straight line just 

drag to the next point and click.  You can continue to make a straight line or when you 

click you can make a corner point.  To make a curve, click and drag.  This creates a 

direction line with ñweightsò on either end.  Depending on how you maneuver the 

weights on the end of the direction line changes the depth and angle of the curve.  This 

really takes practice to get the curves to behave.  To edit a curve use the subselection tool 

to select a point.  Move the direction handles to change the curve.  To change just one 

side of the curve click the Alt key.  When you are done with your line double click to end 

it, or move off the path and Ctrl + Click. 

 

Text can be altered in the property inspector.  You can change font, color, size, kerning, 

leading and other options in the property inspector. 

 

 

Web 

The web tools allow you to create hot spots or slice an image. A hot spot allows 

hyperlinks on sections of an image. Slicing an image allows for optimizing (making the 

best quality for the smallest file) of different sections of an image. 

Colors 

In the colors section you can set the color of the stroke (the edge of your 

object) or the fill color.  The pencil color picker sets the stroke and the paint 

bucket color picker sets the fill.  The eyedropper allows you to choose a 

color on screen and set your stroke or fill to that color.  Under the paint 

bucket is the gradient tool which allows for a gradient fill.  The property 

inspector gives many options for fill colors and opacity.  The small icons on 

the bottom of the Colors section will reset the default colors, create no color 

and swap the stroke and fill color. 

 

View 

The view section allows for different screen views from standard to full screen.  Another 

way to get a larger work area is to use the F4 toggle to hide the tools.  

The Hand tool allows you to move an image that is larger than the work 

area around so you can see all the parts of the image.  The magnifier 

zooms in on the image.  Holding down the Alt key while clicking with 

the zoom tool zooms your image out.   

 



Menus 

The Fireworks menu bar offers many 

ways to manipulate 

images/graphics/objects. 

Many options are similar to other applications such as 

the File menu offers options for opening, saving and 

closing images.   

 

Modify 

The Modify menu is more unique to Fireworks.  For 

example the Canvas selection allows you to change 

image size, resize or recolor the canvas, rotate the 

image and trim the canvas to fit your image. 

You can lock a selection so it canôt be altered in error. 

Transform allows you to transform your image or 

your selection.  Selecting several objects and choosing 

Align allows you to align the objects in several 

different ways. 

Text 

One interesting thing you can do with text in Fireworks is that you can draw a path and 

then attach your text to it.  

 

To Align text to path: 

 

1. Create the text. 

2. Create the path 

3. Shift-select both the 

path and the text. 

4. Choose the text menu 

and click on Attach 

to Path  
 

To change the starting point 

of the text change the text 

offset in the Property 

Inspector 



Panels 

The panels in Fireworks can be opened or closed by clicking on the name of the panel.  

They can be turned on and off by going to the Window menu.  They toggle off and on, if 

there is a check in front of the panel name it is on.  If you are looking for a panel and you 

canôt see it look in the Window menu.   

 

Optimize 

To get the smallest file with the best quality you want to 

optimize your image before exporting it to Dreamweaver or 

saving the file.  Use the Optimize panel with the previews to 

get the best image.  Here you can change the type of file and 

the quality. Using the 4-up preview with the optimize panel 

allows you to see the different ways your image will look 

when you change options. Usually a jpeg is best for photo 

type images while a gif is best for illustrations or logos or 

images with few colors. 

 

Layers 

Your images may include many different layers.  Layers in Fireworks are used for 

organization.  Layers in Fireworks are more like a folder for holding bitmap images or 

vector objects. All Fireworks images have a Web layer on top.  The layers can be visible 

or hidden by clicking on the eye toggle.  Layers can be locked to prevent them from 

being moved or altered.   

 

 

 

 

 

 

 

 

 

 

 


